Функции программы Microsoft Excel: оператор «ЕСЛИ»

ITGuides.ru

Вопросы и ответы в сфере it технологий и настройке ПК

Примеры использования функции проверки условия (ЕСЛИ) в Excel

Функция ЕСЛИ относится к логическим функциям Microsoft Excel и является одной из наиболее часто используемых в работе. С помощью этого оператора можно выполнять различные задачи, когда необходимо сравнить какие-то данные и выдать результат. Функция ЕСЛИ в Excel дает возможность использовать в работе ветвящиеся алгоритмы, строить дерево решений и т.д.

Видео по использованию функции ЕСЛИ в Excel

Примеры использования оператора ЕСЛИ

Функция ЕСЛИ выглядит следующим образом:

=ЕСЛИ (выражение; истина; ложь).

А теперь немного подробнее:

  1. Выражение — это логическое выражение, которое может быть числом или фразой. Например «10» — это логическое выражение, «без НДС» — тоже логическое выражение. Это единственный параметр, который заполняется в обязательном порядке.
  2. Истина — значение, которое будет выдано в качестве результата, если выражение окажется истинным.
  3. Ложь — значение, которое будет выдано, если выражение будет ложным.

К примеру, можно ввести в поле C1 цифру 8, а в поле D1 написать так: =ЕСЛИ(C1 );

  • меньше ( =);
  • меньше или равно ( ).
  • Примеры функций И, ИЛИ

    Также при использовании в Экселе функции ЕСЛИ есть возможность соединить ее с простыми операторами сравнения (вроде И, ИЛИ). Например, можно написать такое условие: =ЕСЛИ(И(A1 3); «проходит», «не проходит»). Получается следующее условие: если оценка студента меньше или равна 5 и больше 3, то будет показан комментарий «проходит», в противном случае — «не проходит» (проходят только те студенты, у которых в оценках стоят четверки и пятерки).

    Следующее условие с примером оператора ИЛИ: =ЕСЛИ(ИЛИ(A1=5; A1=10); 100; 0). Получается, что если число в ячейке А1 равняется 5 или 10, то программа выдаст 100, в противном случае — 0.

    Кроме того, можно применять эти простые операторы и для решения более сложных задач. Например, в базе данных необходимо отобрать должников, которые должны более 10 тысяч рублей и уже не платили более 6 месяцев. Если программа найдет такого человека, то пусть выдаст критерий «проблемный заемщик».

    Допустим, в ячейке A1 находится информация о сроке задолженности (в месяцах), а в поле B1 — сумма задолженности. Тогда формула будет выглядеть следующим образом: =ЕСЛИ(И(A1>=6; B1>10000); «проблемный заемщик»; «»). Если будет найден человек, который подходит под указанное условие, то программа напишет напротив его фамилии комментарий «проблемный заемщик», в противном случае ячейка останется пустой.

    Если один из параметров считается критическим, тогда можно составить формулу так: =ЕСЛИ(ИЛИ(A1>=6; B1>10000); «критическая ситуация»; «»). Если программа найдет совпадения хотя бы по одному параметру (либо срок, либо сумма задолженности), то пользователь увидит сообщение о том, что ситуация критическая. Разница с предыдущей формулой в том, что в первом случае сообщение «проблемный заемщик» выдавалось только тогда, когда выполнялись оба условия.

    Другие примеры использования оператора ЕСЛИ

    Очень часто в Экселе возникает такая ошибка, как «ДЕЛ/0», т.е. деление на 0. Как правило, она появляется в техслучаях, когда копируется формула «A/B», а число B в некоторых ячейках равняется нулю. Этого можно избежать, если использовать оператор ЕСЛИ. Для этого необходимо написать так: =ЕСЛИ(B1=0; 0; A1/B1). Получается, что если в ячейке B1 будет ноль, то Excel сразу же выдаст ноль, в противном случае программа поделит A1 на B1 и выдаст результат.

    Еще одна ситуация, которая довольно часто встречается на практике, расчет скидки в зависимости от общей суммы покупки. Для этого понадобится примерно такая матрица:

    • до 1000 — 0%;
    • от 1001 до 3000 — 3%;
    • от 3001 до 5000 — 5%;
    • свыше 5001 — 7%.

    К примеру, в Excel есть условная база данных клиентов и информация о том, сколько они потратили на покупки. Задача состоит в том, чтобы рассчитать для них скидку. Для этого можно написать так: =ЕСЛИ(A1>=5001; B1*0,93; ЕСЛИ(А1>=3001; B1*0,95;..). Суть ясна: проверяется общая сумма покупок, и когда она, к примеру, больше 5001 рублей, то умножается на 93% стоимости товара (ячейка B1*0,93), когда больше 3001 рублей, то умножается на 95% стоимости товара и т.д. Такую формулу легко можно использовать и на практике: уровень объема продаж и уровень скидок устанавливается на ваше усмотрение.

    Таким образом, применять функцию ЕСЛИ можно практически в любой ситуации, функциональность Microsoft Excel это позволяет. Главное — правильно составить формулу, чтобы результат не оказался ошибочным.

    Отблагодари меня, поделись ссылкой с друзьями в социальных сетях:

    Использование оператора «ЕСЛИ» в Microsoft Excel

    Среди многих функций, с которыми работает Microsoft Excel, следует выделить функцию «ЕСЛИ». Это один из тех операторов, к которым пользователи прибегают чаще всего при выполнении задач в программе. Давайте разберемся, что представляет собой эта функция и как с ней работать.

    Общее определение и задачи

    «ЕСЛИ» является стандартной функцией программы Microsoft Excel. В ее задачи входит проверка выполнения конкретного условия. Когда условие выполнено (истина), то в ячейку, где использована данная функция, возвращается одно значение, а если не выполнено (ложь) – другое.

    Синтаксис этой функции выглядит следующим образом: «ЕСЛИ(логическое выражение; [функция если истина]; [функция если ложь])» .

    Пример использования «ЕСЛИ»

    Теперь давайте рассмотрим конкретные примеры, где используется формула с оператором «ЕСЛИ».

    1. Имеем таблицу заработной платы. Всем женщинам положена премия к 8 марту в 1000 рублей. В таблице есть колонка, где указан пол сотрудников. Таким образом, нам нужно вычислить женщин из предоставленного списка и в соответствующих строках колонки «Премия к 8 марта» вписать по «1000». В то же время, если пол не будет соответствовать женскому, значение таких строк должно соответствовать «0». Функция примет такой вид: «ЕСЛИ(B6=»жен.»; «1000»; «0»)» . То есть когда результатом проверки будет «истина» (если окажется, что строку данных занимает женщина с параметром «жен.»), то выполнится первое условие — «1000», а если «ложь» (любое другое значение, кроме «жен.»), то соответственно, последнее — «0».
    2. Вписываем это выражение в самую верхнюю ячейку, где должен выводиться результат. Перед выражением ставим знак «=».

    Так мы получили таблицу со столбцом, заполненным при помощи функции «ЕСЛИ».

    Пример функции с несколькими условиями

    В функцию «ЕСЛИ» можно также вводить несколько условий. В этой ситуации применяется вложение одного оператора «ЕСЛИ» в другой. При выполнении условия в ячейке отображается заданный результат, если же условие не выполнено, то выводимый результат зависит уже от второго оператора.

    1. Для примера возьмем все ту же таблицу с выплатами премии к 8 марта. Но на этот раз, согласно условиям, размер премии зависит от категории работника. Женщины, имеющие статус основного персонала, получают бонус по 1000 рублей, а вспомогательный персонал получает только 500 рублей. Естественно, что мужчинам этот вид выплат вообще не положен независимо от категории.
    2. Первым условием является то, что если сотрудник — мужчина, то величина получаемой премии равна нулю. Если же данное значение ложно, и сотрудник не мужчина (т.е. женщина), то начинается проверка второго условия. Если женщина относится к основному персоналу, в ячейку будет выводиться значение «1000», а в обратном случае – «500». В виде формулы это будет выглядеть следующим образом: «=ЕСЛИ(B6=»муж.»;»0″; ЕСЛИ(C6=»Основной персонал»; «1000»;»500″))» .
    3. Вставляем это выражение в самую верхнюю ячейку столбца «Премия к 8 марта».

    Как и в прошлый раз, «протягиваем» формулу вниз.

    Пример с выполнением двух условий одновременно

    В функции «ЕСЛИ» можно также использовать оператор «И», который позволяет считать истинной только выполнение двух или нескольких условий одновременно.

    1. Например, в нашей ситуации премия к 8 марта в размере 1000 рублей выдается только женщинам, которые являются основным персоналом, а мужчины и представительницы женского пола, числящиеся вспомогательным персоналом, не получают ничего. Таким образом, чтобы значение в ячейках колонки «Премия к 8 марта» было 1000, нужно соблюдение двух условий: пол – женский, категория персонала – основной персонал. Во всех остальных случаях значение в этих ячейках будет рано нулю. Это записывается следующей формулой: «=ЕСЛИ(И(B6=»жен.»; C6=»Основной персонал»); «1000»; «0»)» . Вставляем ее в ячейку.

    Копируем значение формулы на ячейки, расположенные ниже, аналогично продемонстрированным выше способам.

    Пример использования оператора «ИЛИ»

    В функции «ЕСЛИ» также может использоваться оператор «ИЛИ». Он подразумевает, что значение является истинным, если выполнено хотя бы одно из нескольких условий.

      Итак, предположим, что премия к 8 марта в 1000 рублей положена только женщинам, которые входят в число основного персонала. В этом случае, если работник — мужчина или относится к вспомогательному персоналу, то величина его премии будет равна нулю, а иначе – 1000 рублей. В виде формулы это выглядит так: «=ЕСЛИ(ИЛИ(B6=»муж.»; C6=»Вспомогательный персонал»); «0»; «1000»)» . Записываем ее в соответствующую ячейку таблицы.

    «Протягиваем» результаты вниз.

    Как видим, функция «ЕСЛИ» может оказаться для пользователя хорошим помощником при работе с данными в Microsoft Excel. Она позволяет отобразить результаты, соответствующие определенным условиям.

    Использование ЕСЛИ с функциями И, ИЛИ и НЕ

    Функция ЕСЛИ позволяет выполнять логические сравнения значений и ожидаемых результатов. Она проверяет условие и в зависимости от его истинности возвращает результат.

    =ЕСЛИ(это истинно, то сделать это, в противном случае сделать что-то еще)

    Но что делать, если необходимо проверить несколько условий, где, допустим, все условия должны иметь значение ИСТИНА или ЛОЖЬ ( И), только одно условие должно иметь такое значение ( ИЛИ) или вы хотите убедиться, что данные НЕ соответствуют условию? Эти три функции можно использовать самостоятельно, но они намного чаще встречаются в сочетании с функцией ЕСЛИ.

    Используйте функцию ЕСЛИ вместе с функциями И, ИЛИ и НЕ, чтобы оценивать несколько условий.

    ЕСЛИ(И()): ЕСЛИ(И(лог_выражение1; [лог_выражение2]; …), значение_если_истина; [значение_если_ложь]))

    ЕСЛИ(ИЛИ()): ЕСЛИ(ИЛИ(лог_выражение1; [лог_выражение2]; …), значение_если_истина; [значение_если_ложь]))

    ЕСЛИ(НЕ()): ЕСЛИ(НЕ(лог_выражение1), значение_если_истина; [значение_если_ложь]))

    Условие, которое нужно проверить.

    Значение, которое должно возвращаться, если лог_выражение имеет значение ИСТИНА.

    Значение, которое должно возвращаться, если лог_выражение имеет значение ЛОЖЬ.

    Общие сведения об использовании этих функций по отдельности см. в следующих статьях: И, ИЛИ, НЕ. При сочетании с оператором ЕСЛИ они расшифровываются следующим образом:

    И: =ЕСЛИ(И(условие; другое условие); значение, если ИСТИНА; значение, если ЛОЖЬ)

    ИЛИ: =ЕСЛИ(ИЛИ(условие; другое условие); значение, если ИСТИНА; значение, если ЛОЖЬ)

    НЕ: =ЕСЛИ(НЕ(условие); значение, если ИСТИНА; значение, если ЛОЖЬ)

    Примеры

    Ниже приведены примеры распространенных случаев использования вложенных операторов ЕСЛИ(И()), ЕСЛИ(ИЛИ()) и ЕСЛИ(НЕ()). Функции И и ИЛИ поддерживают до 255 отдельных условий, но рекомендуется использовать только несколько условий, так как формулы с большой степенью вложенности сложно создавать, тестировать и изменять. У функции НЕ может быть только одно условие.

    Ниже приведены формулы с расшифровкой их логики.

    =ЕСЛИ(И(A2>0;B2 0;B4 50);ИСТИНА;ЛОЖЬ)

    Если A6 (25) НЕ больше 50, возвращается значение ИСТИНА, в противном случае возвращается значение ЛОЖЬ. В этом случае значение не больше чем 50, поэтому формула возвращает значение ИСТИНА.

    Если значение A7 («синий») НЕ равно «красный», возвращается значение ИСТИНА, в противном случае возвращается значение ЛОЖЬ.

    Обратите внимание, что во всех примерах есть закрывающая скобка после условий. Аргументы ИСТИНА и ЛОЖЬ относятся ко внешнему оператору ЕСЛИ. Кроме того, вы можете использовать текстовые или числовые значения вместо значений ИСТИНА и ЛОЖЬ, которые возвращаются в примерах.

    Вот несколько примеров использования операторов И, ИЛИ и НЕ для оценки дат.

    Ниже приведены формулы с расшифровкой их логики.

    Если A2 больше B2, возвращается значение ИСТИНА, в противном случае возвращается значение ЛОЖЬ. В этом случае 12.03.14 больше чем 01.01.14, поэтому формула возвращает значение ИСТИНА.

    =ЕСЛИ(И(A3>B2;A3 B2;A4 B2);ИСТИНА;ЛОЖЬ)

    Если A5 не больше B2, возвращается значение ИСТИНА, в противном случае возвращается значение ЛОЖЬ. В этом случае A5 больше B2, поэтому формула возвращает значение ЛОЖЬ.

    Использование операторов И, ИЛИ и НЕ с условным форматированием

    Вы также можете использовать операторы И, ИЛИ и НЕ в формулах условного форматирования. При этом вы можете опустить функцию ЕСЛИ.

    На вкладке Главная выберите Условное форматирование > Создать правило. Затем выберите параметр Использовать формулу для определения форматируемых ячеек, введите формулу и примените формат.

    «Изменить правило» с параметром «Формула»» xmlns_AntiXSS=»urn:AntiXSSExtensions» />

    Вот как будут выглядеть формулы для примеров с датами:

    Если A2 больше B2, отформатировать ячейку, в противном случае не выполнять никаких действий.

    =И(A3>B2;A3 B2;A4 B2)

    Если A5 НЕ больше B2, отформатировать ячейку, в противном случае не выполнять никаких действий. В этом случае A5 больше B2, поэтому формула возвращает значение ЛОЖЬ. Если изменить формулу на =НЕ(B2>A5), она вернет значение ИСТИНА, а ячейка будет отформатирована.

    Примечание: Наиболее распространенная ошибка заключается в том, чтобы ввести формулу в условное форматирование без знака равенства (=). Если вы сделаете это, вы увидите, что в диалоговом окне «условное форматирование» добавляется знак равенства и кавычки к формуле = = «или (a4>B2; a4

    Дополнительные сведения

    Вы всегда можете задать вопрос специалисту Excel Tech Community, попросить помощи в сообществе Answers community, а также предложить новую функцию или улучшение на веб-сайте Excel User Voice.

    Оператор “ЕСЛИ” в программе Microsoft Excel: применение и примеры

    Программа Excel, безусловно, обладает очень богатым функционалом. И среди множества разнообразных инструментов особое место занимает оператор «ЕСЛИ». Он помогает в решении совершенно различных задач, и к этой функции пользователи обращаются намного чаще, чем к остальным.

    В этой статье мы поговорим о том, что же такое оператор «ЕСЛИ», а также рассмотрим область применения и принципы работы с ним.

    Содержание: Функция “ЕСЛИ” в Excel

    Определение функции “ЕСЛИ” и ее назначение

    Оператор «ЕСЛИ» – это инструмент программы Эксель для проверки определенного условия (логического выражения) на выполнение.

    То есть, представим, что у нас есть какое-то условие. Задача “ЕСЛИ” – проверить соблюдение данного условия и вывести в ячейку с функцией значение, основанное на результате проверки.

    1. Если логического выражение (условие) выполняется, то значение соответствует истине.
    2. Если логического выражение (условие) не выполняется, значение является ложным.

    Сама формула функции в программе представляет собой следующее выражение:

    =ЕСЛИ(условие; [значение если условие выполнено]; [значение если условие не выполнено])

    Использование функции “ЕСЛИ” на примере

    Вероятно, вышеизложенная информация может показаться не такой понятной. Но, на самом деле ничего сложного здесь нет. И для того, чтобы лучше понять назначение функции и ее работу рассмотрим пример ниже.

    У нас есть таблица с наименованиями спортивной обуви. Представим, что скоро у нас будет распродажа, и всей женской обуви нужно проставить скидку 25%. В одном из столбцов в таблице как раз прописан пол для каждого наименования.

    Наша задача — в столбце “Скидка” вывести значение «25%» для всех строк с наименованиями для женского пола. И соответственно, значение «0», если в столбце «Пол» стоит значение «мужской»

    Заполнение данных вручную займет немало времени, и есть высокая доля вероятности где-то ошибиться, особенно, если список длинный. Гораздо проще в этом случае будет автоматизировать процесс при помощи оператора «ЕСЛИ».

    Для выполнения этой задачи потребуется составить следующую формулу ниже:

    =ЕСЛИ(B2=”женский”;25%;0)

    • Логическое выражение: B2=”женский”
    • Значение в случае, условие выполняется (истина) – 25%
    • Значение, если условие не выполняется (ложь) – 0.

    Данную формулу пишем в самой верхней ячейке столбца “Скидка” и нажимаем Enter. Не забываем ставить знак равно (=) перед формулой.

    После этого для данной ячейки будет отображен результат согласно нашему логическому условию (на забываем настроить формат ячеек – процентный). Если проверка выявит, что пол «женский» – будет выведено значение 25%. В противном случае значение ячейки будет равно 0. Собственно говоря, что нам и требовалось.

    Теперь осталось только скопировать данное выражение на все строки. Для этого подведите курсор мыши к правому нижнему краю ячейки с формулой. Указатель мышки при этом должен превратиться в крестик. Зажмите левую кнопку мыши и растяните формулу на все строки, которые нужно проверить согласно заданным условиям.

    Вот и все, теперь мы применили условие ко всем строкам и получили результат для каждой из них.

    Применение «ЕСЛИ» с несколькими условиями

    Мы только что рассмотрели пример использования оператора «ЕСЛИ» с одним логическим выражением. Но в программе также имеется возможность задавать больше одного условия. При этом сначала будет проводиться проверка по первому, и в случае его успешного выполнения сразу отобразится заданное значение. И только если не будет выполнено первое логическое выражение, в силу вступит проверка по второму.

    Рассмотрим наглядно на примере все той же таблицы. Но на этот раз усложним задачу. Теперь нужно проставить скидку на женскую обувь в зависимости от вида спорта.

    Первое условия – это проверка пола. Если “мужской” – сразу выводится значение 0. Если же это “женский”, то начинается проверка по второму условию. Если вид спорта бег – 20%, если теннис – 10%.

    Пропишем формулу для этих условий в нужной нам ячейке.

    =ЕСЛИ(B2=”мужской”;0; ЕСЛИ(C2=”бег”;20%;10%))

    Щелкаем Enter и получаем результат согласно заданным условиям.

    Далее растягиваем формулу на все оставшиеся строки таблицы.

    Одновременное выполнение двух условий

    Также в Эксель существует возможность вывести данные по одновременному выполнению двух условий. При этом значение будет считаться ложным, если хотя бы одно из условий не выполнено. Для этой задачи применяется оператор «И».

    Рассмотрим на примере нашей таблицы. Теперь скидка 30% будет проставлена только, если это женская обувь и предназначена для бега. При соблюдении этих условий одновременно значение ячейки будет равно 30%, в противном случае – 0.

    Для этого используем следующую формулу:

    =ЕСЛИ(И(B2=”женский”;С2=”бег”);30%;0)

    Нажимаем клавишу Enter, чтобы отобразить результат в ячейке.

    Аналогично примерам выше, растягиваем формулу на остальные строки.

    Оператор «ИЛИ»

    В этом случае значение логического выражения считается истинным при выполнении одного из условий. Второе условие при этом может не выполняться.

    Поставим задачу следующим образом. Скидка 35% предоставляется только на мужскую обувь для тенниса. Если это мужская обувь для бега или любая женская обувь, скидка равна 0.

    В данном случае нужна следующая формула:

    =ЕСЛИ(ИЛИ(B2=”женский”; C2=”бег”);0;35%)

    После нажатия Enter мы получим требуемое значение.

    Растягиваем формулу вниз и скидки для всего ассортимента готовы.

    Как задать функции ЕСЛИ через Построитель формул

    Использовать функцию ЕСЛИ можно не только прописывая ее вручную в ячейке или строке формул, но также и через Построитель формул.

    Давайте разберем, как это работает. Допустим, нам снова как и в первом примере нужно проставить скидку на всю женскую обувь в размере 25%.

    1. Ставим курсор на нужную ячейку, заходим во вкладку “Формулы”, далее щелкаем “Вставить функцию”.
    2. В открывшемся списке Построителя формул выбираем “ЕСЛИ” и нажимаем “Вставить функцию”.
    3. Открывается окно настройки функции. В поле “логическое выражение” пишем условие, по которому будет проводиться проверка. В нашем случае это “B2=”женский”.
      В поле “Истина” пишем значение, которое должно отобразиться в ячейке, если условие выполняется.
      В поле “Ложь” – значение при невыполнении условия.
    4. После того, как все поля заполнены, жмем “Готово”, чтобы получить результат.

    Заключение

    Одним из самых популярных и полезных инструментов в Excel является функция ЕСЛИ, которая проверяет данные на совпадение заданным нами условиям и выдает результат в автоматическом режиме, что исключает возможность ошибок из-за человеческого фактора. Поэтому, знание и умение применять этот инструмент позволит сэкономить время не только на выполнение многих задач, но и на поиски возможных ошибок из-за “ручного” режима работы.

    Функции Excel ЕСЛИ (IF) и ЕСЛИМН (IFS) для нескольких условий

    Логическая функция ЕСЛИ в Экселе – одна из самых востребованных. Она возвращает результат (значение или другую формулу) в зависимости от условия.

    Функция ЕСЛИ в Excel

    Функция имеет следующий синтаксис.

    ЕСЛИ(лог_выражение; значение_если_истина; [значение_если_ложь])

    лог_выражение – это проверяемое условие. Например, A2 30) не выполняется и возвращается альтернативное значение, указанное в третьем поле. В этом вся суть функции ЕСЛИ. Протягивая расчет вниз, получаем результат по каждому товару.

    Однако это был демонстрационный пример. Чаще формулу Эксель ЕСЛИ используют для более сложных проверок. Допустим, есть средненедельные продажи товаров и их остатки на текущий момент. Закупщику нужно сделать прогноз остатков через 2 недели. Для этого нужно от текущих запасов отнять удвоенные средненедельные продажи.

    Пока все логично, но смущают минусы. Разве бывают отрицательные остатки? Нет, конечно. Запасы не могут быть ниже нуля. Чтобы прогноз был корректным, нужно отрицательные значения заменить нулями. Здесь отлично поможет формула ЕСЛИ. Она будет проверять полученное по прогнозу значение и если оно окажется меньше нуля, то принудительно выдаст ответ 0, в противном случае — результат расчета, т.е. некоторое положительное число. В общем, та же логика, только вместо значений используем формулу в качестве условия.

    В прогнозе запасов больше нет отрицательных значений, что в целом очень неплохо.

    Формулы Excel ЕСЛИ также активно используют в формулах массивов. Здесь мы не будем далеко углубляться. Заинтересованным рекомендую прочитать статью о том, как рассчитать максимальное и минимальное значение по условию. Правда, расчет в той статье более не актуален, т.к. в Excel 2016 появились функции МИНЕСЛИ и МАКСЕСЛИ. Но для примера очень полезно ознакомиться – пригодится в другой ситуации.

    Формула ЕСЛИ в Excel – примеры нескольких условий

    Довольно часто количество возможных условий не 2 (проверяемое и альтернативное), а 3, 4 и более. В этом случае также можно использовать функцию ЕСЛИ, но теперь ее придется вкладывать друг в друга, указывая все условия по очереди. Рассмотрим следующий пример.

    Нескольким менеджерам по продажам нужно начислить премию в зависимости от выполнения плана продаж. Система мотивации следующая. Если план выполнен менее, чем на 90%, то премия не полагается, если от 90% до 95% — премия 10%, от 95% до 100% — премия 20% и если план перевыполнен, то 30%. Как видно здесь 4 варианта. Чтобы их указать в одной формуле потребуется следующая логическая структура. Если выполняется первое условие, то наступает первый вариант, в противном случае, если выполняется второе условие, то наступает второй вариант, в противном случае если… и т.д. Количество условий может быть довольно большим. В конце формулы указывается последний альтернативный вариант, для которого не выполняется ни одно из перечисленных ранее условий (как третье поле в обычной формуле ЕСЛИ). В итоге формула имеет следующий вид.

    Комбинация функций ЕСЛИ работает так, что при выполнении какого-либо указанно условия следующие уже не проверяются. Поэтому важно их указать в правильной последовательности. Если бы мы начали проверку с B2 =1. Однако этого можно избежать, если в поле с условием написать ИСТИНА, указывая тем самым, что, если не выполняются ранее перечисленные условия, наступает ИСТИНА и возвращается последнее альтернативное значение.

    Теперь вы знаете, как пользоваться функцией ЕСЛИ в Excel, а также ее более современным вариантом для множества условий ЕСЛИМН.

    Функция ЕСЛИ в Excel с примерами нескольких условий

    Логический оператор ЕСЛИ в Excel применяется для записи определенных условий. Сопоставляются числа и/или текст, функции, формулы и т.д. Когда значения отвечают заданным параметрам, то появляется одна запись. Не отвечают – другая.

    Логические функции – это очень простой и эффективный инструмент, который часто применяется в практике. Рассмотрим подробно на примерах.

    Синтаксис функции ЕСЛИ с одним условием

    Синтаксис оператора в Excel – строение функции, необходимые для ее работы данные.

    Разберем синтаксис функции:

    Логическое_выражение – ЧТО оператор проверяет (текстовые либо числовые данные ячейки).

    Значение_если_истина – ЧТО появится в ячейке, когда текст или число отвечают заданному условию (правдивы).

    Значение,если_ложь – ЧТО появится в графе, когда текст или число НЕ отвечают заданному условию (лживы).

    Оператор проверяет ячейку А1 и сравнивает ее с 20. Это «логическое_выражение». Когда содержимое графы больше 20, появляется истинная надпись «больше 20». Нет – «меньше или равно 20».

    Внимание! Слова в формуле необходимо брать в кавычки. Чтобы Excel понял, что нужно выводить текстовые значения.

    Еще один пример. Чтобы получить допуск к экзамену, студенты группы должны успешно сдать зачет. Результаты занесем в таблицу с графами: список студентов, зачет, экзамен.

    Обратите внимание: оператор ЕСЛИ должен проверить не цифровой тип данных, а текстовый. Поэтому мы прописали в формуле В2= «зач.». В кавычки берем, чтобы программа правильно распознала текст.

    Функция ЕСЛИ в Excel с несколькими условиями

    Часто на практике одного условия для логической функции мало. Когда нужно учесть несколько вариантов принятия решений, выкладываем операторы ЕСЛИ друг в друга. Таким образом, у нас получиться несколько функций ЕСЛИ в Excel.

    Синтаксис будет выглядеть следующим образом:

    Здесь оператор проверяет два параметра. Если первое условие истинно, то формула возвращает первый аргумент – истину. Ложно – оператор проверяет второе условие.

    Примеры несколько условий функции ЕСЛИ в Excel:

    Таблица для анализа успеваемости. Ученик получил 5 баллов – «отлично». 4 – «хорошо». 3 – «удовлетворительно». Оператор ЕСЛИ проверяет 2 условия: равенство значения в ячейке 5 и 4.

    В этом примере мы добавили третье условие, подразумевающее наличие в табеле успеваемости еще и «двоек». Принцип «срабатывания» оператора ЕСЛИ тот же.

    Расширение функционала с помощью операторов «И» и «ИЛИ»

    Когда нужно проверить несколько истинных условий, используется функция И. Суть такова: ЕСЛИ а = 1 И а = 2 ТОГДА значение в ИНАЧЕ значение с.

    Функция ИЛИ проверяет условие 1 или условие 2. Как только хотя бы одно условие истинно, то результат будет истинным. Суть такова: ЕСЛИ а = 1 ИЛИ а = 2 ТОГДА значение в ИНАЧЕ значение с.

    Функции И и ИЛИ могут проверить до 30 условий.

    Пример использования оператора И:

    Пример использования функции ИЛИ:

    Как сравнить данные в двух таблицах

    Пользователям часто приходится сравнить две таблицы в Excel на совпадения. Примеры из «жизни»: сопоставить цены на товар в разные привозы, сравнить балансы (бухгалтерские отчеты) за несколько месяцев, успеваемость учеников (студентов) разных классов, в разные четверти и т.д.

    Чтобы сравнить 2 таблицы в Excel, можно воспользоваться оператором СЧЕТЕСЛИ. Рассмотрим порядок применения функции.

    Для примера возьмем две таблицы с техническими характеристиками разных кухонных комбайнов. Мы задумали выделение отличий цветом. Эту задачу в Excel решает условное форматирование.

    Исходные данные (таблицы, с которыми будем работать):

    Выделяем первую таблицу. Условное форматирование – создать правило – использовать формулу для определения форматируемых ячеек:

    В строку формул записываем: =СЧЕТЕСЛИ (сравниваемый диапазон; первая ячейка первой таблицы)=0. Сравниваемый диапазон – это вторая таблица.

    Чтобы вбить в формулу диапазон, просто выделяем его первую ячейку и последнюю. «= 0» означает команду поиска точных (а не приблизительных) значений.

    Выбираем формат и устанавливаем, как изменятся ячейки при соблюдении формулы. Лучше сделать заливку цветом.

    Выделяем вторую таблицу. Условное форматирование – создать правило – использовать формулу. Применяем тот же оператор (СЧЕТЕСЛИ).

    Здесь вместо первой и последней ячейки диапазона мы вставили имя столбца, которое присвоили ему заранее. Можно заполнять формулу любым из способов. Но с именем проще.